1. FEX Deploymnet Model
1-1. Straight-through FEX using static pinning
static pinning이란 FEX의 downlink server port가 FEX와 switch간의 uplinks중 하나를 고정적으로 선택해서 특정
서버로의 트래픽이 항상 같은 uplink를 사용하게 한다.
1-2. Straight-through FEX using dynamic pinning
FEX와 서버간의 Ports들은 Port channel를 사용하여 하나의 포트로 구성되어지며, 트래픽은 Port channel hashing mechanism에 따라 로드밸런싱이 된다.
1-3. Active-active FEX using vPC : Port channels과 vPC 를 사용해야 한다.
FEX는 dual-homed방식으로 vPC기술을 이용해서 두개의 Cisco Nexus switch에 연결된다.
2. Dynamic Pinning
- 이 deploymnet 방식은 Cisco Nexus 2000 Series switch와 5000 Series switch간에서 port channel 구성통해 이루어질 수 있다.
- 설정 방법
Switch(config)# feature fex
Switch(config)# fex 121
Switch(config-fex)# description "FEX 121, rack 2"
Switch(config-fex)# pinning max-link 1
Switch(config)# interface ethernet 1/9-12
Swtich(config-if-range)# switchport mode fex-fabric
Switch(config-if-range)# channel-group 21
Switch(config)# interface port-channel 21
Switch(config-if)# fax associate 121
cf) ping max-link를 1로 한 이유는, 모든 포트가 각각의 포트대신에 논리적으로 하나로 생성된 port-channel를 사용하기 때문이다.
Cisco Nexus 7000 Series에서는 "pinning max-links"가 지원되어 않는다 왜나하면 Dynamic Pinning만 지원되기 때문이다.
[Cisco Nexus 7000에서 Dynamic Pinning설정하기]
Nxus7K(config)# intall feature-set fex
Nxus7K# switchto vdc RED
Nxus7K-RED(config)# feature-set fex
Nxus7K-RED(config)# fex 141
Nxus7K-RED(config)# description "FEX 141, rack 4"
Nxus7K-RED(config)# interface ethernet 1/1-2, ethernet 1/9-10
Nxus7K-RED(config-if-range)# switchport mode
Nxus7K-RED(config-if-range)# switchport mode fex-fabric
Nxus7K-RED(config-if-range)# channel-group 41
Nxus7K-RED(config-if-range)# no shutdown
Nxus7K-RED(config-if-range)# interface port-channel 41
Nxus7K-RED(config-if-range)# fax associate 141
3. Active-active FEX
- 이 deployment방식은 Cisco Nexus 5000 Series Switch가 2000 Series FEX를 관리한다. 두 스위치는 같은 설정을 가져야 하며 vPC설정으로 FEX uplinks들을 하나의 single port channel로 만들야 한다. 이것은 uplinks, FEX 또는 스위치의 장애에 대한 HA를 구성방식이다.
- Port channel은 서버와 FEX간에는 설정을 할 수가 없으나, 서버의 HA와 로드밸런싱을 위해 서버에서 NIC에 대한 teaming option을 선택할 수 있다.
- 설정방법
SwitchA(config)#feature fex
SwitchA(config)#fex 131
SwtichA(config-fex)# desc "Fex 131, rack 1"
SwtichA(config-fex)# pinning max-links 1
SwtichA(config)#interface ethernet 1/17-20
SwtichA(config-if-range)# switchport mode fex-fabric
SwtichA(config-if-range)# channel-group 31
SwtichA(config)# feature vpc
SwtichA(config)# vpc domain 37
SwtichA(config-vpn-domain)# peer-keepalive destination 192.168.1.2
SwtichA(config)#interface ethernet 1/31-32
SwtichA(config-if-range)# channel-group 1
SwtichA(config)# interface port-channel 1
SwtichA(config-if)# switchport port-channel 1
SwtichA(config-if)# vpc peer-link
SwitchA(config)# interface port-channel 31
SwtichA(config-if)# vcp 31
SwtichA(config-if)# fex assocate 131
SwtichA(config)# interface ethernet 131/1/1
SwtichA(config-if)# switchport access vlan 10
SwtichB(config)# interface ethernet 131/1/1
SwtichB(config-if)# switchport access vlan 10
4. Switch Profile
이 특징은 Cisco Nexus 500/5500 Series Switch에서만 지원된다.
다음의 설정모드를 포함한다.
-Configuation synchronization mode(config-sync)
-Switch profile mode
-Switch profile import mode
설정
Switch(config)# cfs ipv4 distribute
Switch(config-sync)# switch-profile PC-profile
Switch(config-sync-sp)# sync-peer destination 10.1.1.2
Switch(config-sync-sp)# show switch-profile PC-profile status
Switch(config-sync-sp)# interface ethernet 1/1-16
Switch(config-sync-sp-if-range)# switchport
Switch(config-if-range)# channel-group 1
Switch(config-sync-sp)# interface port-channel 1
Switch(config-sync-sp-if)# <.... Layer 2/3 configuraiton ....>
Switch(config-sync-sp-if)#show switch-profile switch-profile buffer
Switch(config-sync-sp-if)# commit
Switch(config-sync)# show switch-profile switch-profile status
5. Configuring Enhanced vPCs
5-1. Two-layer vPC라고 알려진 Enhanced vPC 특징은 하나의 솔류션에서 두가지의 dual-homing으로 합한것이다.
- Dual-homed connection of a host to two EFXs.
- Dual-homed connection of an FEX to two switches.
==> Fex dual-homed to two switches
5-2. Enhanced vPC는 Cisco Nexus 5500 Platform(5.1(3)N1(1) 이후)에서 지원되고 Cisco Nexus2000 Series Fabric Extender과 같이 구성되어질 수 있다.
5-3. Enchaned vPC에서 지원가능한 Topologies
- Singled-homed server connected to a single FEX
- Dual-homed server connected by a port channel to a single FEX
- Dual-homed server connected by a port channel to a pair of FEXs
-Dual-homed server connected by active/standby NIC teaming to two FEXs
5-4. 권장되지 않는 Topologies
- Dual-homed server connected to a pair of FEXs that connect to a single switch
- Multihomed server connected by a port channel to more than two FEXs
5-5. Enchaned vCP Scalability
- FEXs의 수를 증가 시키지는 않는다.
- Bandwidth를 두배로 한다.
- Reslience를 제공한다.
System | Number of FEXs supported with L2-only configuration | Number of FEXs supported with L3-only configuration |
Nexus 5500 | 24 | 8 |
Dual-homed FEX(Enhanced vPC) | 24(managed byu a pair of 5500) | 8 (managed byu a pair of 5500) |
5-6. Enhanced vPC Configuration
N5500-1(config)# feature vpc
N5500-1(config)# feature lacp
N5500-1(config)# vpc domain 123
N5500-1(config-vpc)# peer-keepalive destinatino 10.1.1.2
N5500-1(config)# interfacet eth 1/1-2
N5500-1(config-if)# channel-group 1 mode active
N5500-1(config-if)# interface po 1
N5500-1(config-if )# switchport mode trunk
N5500-1(config-if )# vpc peer-link
N5500-1(config)# fex 101
N5500-1(config-fex)# interface eth1/3-4
N5500-1(config-if)# channel-group 101
N5500-1(config-if)# interface po 101
N5500-1(config-if)# swtichport mode fex-fabrix
N5500-1(config-if)# vpc 101
N5500-1(config-if)# fex associae 101
N5500-1(config)# fex 102
N5500-1(config-fex)# interface eth1/5-6
N5500-1(config-if)# channel-group 102
N5500-1(config-if)# interface po 102
N5500-1(config-if)# swtichport mode fex-fabrix
N5500-1(config-if)# vpc 102
N5500-1(config-if)# fex associae 102
N5500-1(config)# interface eth101/1/1, eth 101/1/2
N5500-1(config-fex)# channel-group 2 mode active
N5500-1(config-if)# interface eth102/1/1, eth102/1/2
N5500-1(config-if)# channel-group 2 mode active
N5500-1(config-if)# int po2
N5500-1(config-if)# switchport active vlan 10
'네트워크 > Cisco' 카테고리의 다른 글
[네트워크] Cisco Nexus vPC (0) | 2023.07.07 |
---|---|
[네트워크] Cisco Nexus VDC 설명 (0) | 2023.07.07 |
[네트워크] cisco Nexus 9000 시리즈 tcpdump 확인방법 (0) | 2023.07.04 |
[네트워크] Cisco Nexus(NX-OS) 팁 및 요령 (0) | 2023.06.30 |
[네트워크] Cisco Nexus HSRP/VRRP 설정 (0) | 2023.06.30 |